Mech Warrior 4 & Other Online Clan Games >> Installation Instructions for MW4 Mercs >> Cannonfodders Thread

Cannonfodders Thread
Post by Yardbird on Jul 23rd, 2011, 11:15am

Cannon..please post your details here



Specific problem:

Re: Cannonfodders Thread
Post by Jackolope on Jul 23rd, 2011, 1:04pm

Lifted from the shoutbox -

OS - Vista Home

Error message -
User Image

For the record - I think both Ra and Spiff are having the same problem.
Re: Cannonfodders Thread
Post by Yardbird on Jul 23rd, 2011, 5:15pm

OK..looks like they may have an early beta of MXC...please uninstall the MXC and use the current MXC here:


Re: Cannonfodders Thread
Post by SpiffCat on Jul 24th, 2011, 12:03am

I did see that problem, too. I think it was due to user error when the MTX extractor started running. I think I pressed the Start button two times (my mouse button is acting up). And I got a message saying an extraction was already in process and it said it was going to quit.

The initial extraction process still seemed to be running until it got hung up on updating a text file. Eventually I quit. When I tried to install again, I got the error Cannon posted.

To get around it, I when to the MXC folder under program files and ran the MTX program as an administrator. I was careful to then click the start button once. It seemed to finish successfully.

I then went into MCX and it did not think Mercs was installed! Wot the heck?

I quit MCX and noticed that I had a Mercs icon on my desktop. I clicked it and it asked for the usual graphics settings and seemed to fire up like normal! I could even go to the multiplayer servers.

The only problem is that I am running version

I am now going to try to run MCX again to see if I can get the later patches.

Oh, by the way, I'm running Windows 7

-- AlmostThereCat
Re: Cannonfodders Thread
Post by itmecannonfodder on Aug 5th, 2011, 8:57pm

ok install went well have game updated to 30c .. game runs if i click the mercs icon .. the mtx lobby says no mercs ??

os: windows vista home
comp . dell laptop inspipron 1545
av.. avast home

i see mek server through normal games connection to net do i need do like veng and make connection through ip addresses ?
Re: Cannonfodders Thread
Post by Anona Jack on Aug 5th, 2011, 9:30pm

disable firewall and active virus scanning... see if this works/
Re: Cannonfodders Thread
Post by itmecannonfodder on Aug 5th, 2011, 10:51pm

i disabled av and firewalls still not seeing game with lobby .. i can see server in regular game connection just cant join them .. even started to config joystick in game but cant change the buttons set up >.< controler is working and it in list just wont change in game setup/default
Re: Cannonfodders Thread
Post by Jackolope on Aug 6th, 2011, 12:17am

This sounds like a bad install! CD will be in the mail tomorrow (how much is postage to Canada? shocked but in the mean time... try downloading the game again. Just uninstall the game and try it again from the top with firewall and antivirus off and see if that helps. When you download the game (or install) try to let it finish in one sitting.

Anyone else got any ideas?

*burns disk nao*
Re: Cannonfodders Thread
Post by AnonaJackMakinCDSolope on Aug 6th, 2011, 12:11pm

SPAMBOT! jk. Alright, I made the CD and it is in the mail! (YAY) BUT I managed to screw something up. I forgot to include the Varients folder for mercs in there. The game will likely crash when going to mechlab with out it. but thats ok! I can just email you that file and you can put it in your resource folder!

The CD contains a README file, (do it) and the folder for MW4 Mercs 3,1. I managed to get ALL THE MAPS on there too! So you should be set! CD should get there within a week (I guess) but I'd keep trying the game in the mean time.

To anyone else out there that NEEDS a good install of mercs and cant download it.. just email or private message me with an address so I can send a REAL CD to your house. (future CDS will contain varients folder... mah bad)

*off topic note* I don't know how the spambots gets through the captcha.. I've spent 4 tries now trying to figure out what the heck it says! Is that an L or a 1>?
Re: Cannonfodders Thread
Post by Jackolope on Aug 9th, 2011, 2:25pm

GAK! The cd came back in the mail saying I didn't go through customs. Waffles... I'll mail it off from UPS later this week. Sorry man!
Re: Cannonfodders Thread
Post by Jackolope on Aug 20th, 2011, 01:57am

Alright, Some time ago I made a DVD of mechwarrior mercs and sent it to Cannonfodder..... the following.. is what happened....

Re: Cannonfodders Thread
Post by Cannonfodder on Aug 20th, 2011, 1:53pm

got cd and varients installed , note had small problem with option.ini file , needed to remove the read only option on that file and game loaded fine .. the mxc install ver 52 setup went well aswell both installs ran ok
User Image
User Image
User Image
Re: Cannonfodders Thread
Post by Cannonfodder on Aug 20th, 2011, 2:00pm

all avast was turned off and firewall aswell , belive the problem is with the router , going get someone to try and sort out router my last 3 experiences with dealing with routers ended with them stomped in the corner .. routers are not idiot proof >.<... i can see servers in mxc and game lobby i even saw buns smiley ... other then the router game wont allow me to redo/reset joystick controler setting on game ?? any ideas or am i just not doing the reset of buttons right??
Re: Cannonfodders Thread
Post by SpiffCat on Aug 20th, 2011, 4:13pm

Random thought... have you tried running Mercs as an Administrator? Right-click on the Mercs icon and choose that option. I couldn't join the wppc server because of network problems at first... can't remember if this fixed it or not (running windows 7).

-- GoodLuckCat
Re: Cannonfodders Thread
Post by Cannonfodder on Aug 20th, 2011, 5:29pm

all was ran as admin .. still no jump out to server
Re: Cannonfodders Thread
Post by Jackolope on Aug 20th, 2011, 9:10pm

can you get a screenshot of your ports?

S tatic addressing
Since your original Dynamic (DHCP) addressing scheme has kept you from
connecting to MW4, (among many other programs) you will want to change to Static
addressing. How it works simplified – You choose an address for your computer & tell the
router what that address is. When your computer is turned on it always has the same
address. Now you will be able to open the “ports” needed for 2 way negotiations and
communications to each individual computer as needed for many games and programs.
The information here > http://www.homenethelp.com/web/howto/static-ipa
ddress.asp will help you change over to the internal STATIC addressing scheme.
If you plan on having 2 or more computers in your home running the same games or
programs at the same time, you will need to configure each computer as detailed in
the how-to and give each one its own unique static IP address.
Note! Choose addresses above the 100 range for your computer(s).
Example > Computer A = Computer B = Computer C = and so on.
After you have setup static addressing on your router and computer(s), you
will need to re-boot the router first and then the computers. Having re-booted your
r outer/computer(s), you should check and make sure they all connect to the Internet.
I suggest you write each computer(s) STATIC address on a small sticker and stick it
to the case. It will assure quick ease of access to the computers address.
Single computer & router setup for on-line MechWarrior4
P orts:
MW4 requires (like many other programs) ports to be opened in your router
f or communication flow to and from the Internet to your computer.
Ports must be opened in your routers port forwarding configuration page, and they
must be forwarded (opened to) the address of the computer you wish to play on.
One of the best links for port forwarding is here > http://portforward.com/ Do
not use the listed ports for MechWarrior 4 at that site. Use only the ports below.
If you do a search on the Internet on How to Port forward (your router name), you will
probably hit the jackpot and have the exact router adjustment procedure for your router.
The following is the list of ports that will need to be opened in your router to
your computers network address to facilitate the required 2-way communication.
• To guarantee DirectPlay compatibility, the latest version of DirectX should be
i nstalled on the computers that are used by all players who participate in the game.
• The following TCP and UDP ports must be open on the firewall or proxy server:
****Using DirectX 7 or an earlier version (MW4 is DX7)****
Choose 1 Only
Ports for Host configuration (Server)
Initial TCP Connection 47624 Outbound 47624 Inbound
Subsequent TCP Inbound 2300-2400 2300-2400
Subsequent TCP Outbound 2300-2400 2300-2400
Subsequent UDP Inbound 2300-2400 2300-2400
Subsequent UDP Outbound 2300-2400 2300-2400
Ports for Client configuration only (Gamer)
Subsequent TCP Inbound 2300-2400 2300-2400
Subsequent TCP Outbound 2300-2400 2300-2400
Subsequent UDP Inbound 2300-2400 2300-2400
Subsequent UDP Outbound 2300-2400 2300-2400
Note! You CANNOT have the server port 47624 open to more than (1) computer.
You can play on a server-configured machine.

Re: Cannonfodders Thread
Post by Cannonfodder on Aug 21st, 2011, 4:11pm

User Image
User Image
where do i go from here .. at this point i normaly use a hammer cheesy
Re: Cannonfodders Thread
Post by Jackolope on Aug 21st, 2011, 4:52pm

Ok, first make your pc have a static ip address. This will be the first part... get ready for some manual labor..

Go to Local Network

(if using windows 7 then its > Control Panel\Network and Internet\Network and Sharing Center)

local network settings.
Network settings => your LAN or WLAN connection / right click = properties => TCP/IP / right click = properties =>
Fill in the entries:
fix IP: (IT CAN BE .101 OR .10X)
subnet mask:
standard gateway: [your router's IP]
DNS server: [your router's IP] (usually "")

Looks like this:
User Image

Then go into your router and find add ports

Ports for Client configuration only (Gamer)

The following TCP ports must be open:
27999, 28805, 28806, 28807, 28808
47624 Inbound
2300-2400 Inbound

The following UDP port must be open:

Subsequent TCP Inbound 2300-2400 2300-2400
Subsequent TCP Outbound 2300-2400 2300-2400
Subsequent UDP Inbound 2300-2400 2300-2400
Subsequent UDP Outbound 2300-2400 2300-2400

As long as you make it look something like that you'll get it up and running.
IF your router asks what is the IP Address of your pc then use the ip address you set up as mentioned above.

Me guessing>

User Image

Name> MW4
Private IP> (your routers ip in the address bar?)
Protocol Type> (You might just set it to BOTH but if you have the room do them each)
Private Port> EACH!! Quote:
27999, 28805, 28806, 28807, 28808(BOTH)
47624 Inbound TCP
2300-2400 BOTH

UDP port must be open:
Schedule> Always

SAVE. Keep doing that and cross your fingers...

*whew, Hadn't done this in a while... Guys? Did I get all that right?

PS. If you need the room you can probably sum 5 rules into one. Quote:
27999-28808 BOTH Then 2300-2400BOTH then 47624 TCP
Then you can just have 3 rules... but I'm not sure this is a great idea but you could probably get by with it.
Re: Cannonfodders Thread
Post by Frost on Sep 2nd, 2011, 4:34pm

@Cannonfodder: I have this D-Link DL-604 router too, so I guess I can give you the info you need:

1) generally check this: http://mw4frost.mw.funpic.de/router_en.html

2) in detail:

- Make sure you assigned your gaming pc a static lan ip, as Jack described above. (s.th. like

- make sure UPNP on router is disabled, otherwise port forwarding won't work properly.

- you only need the port range 2300-2400 tcp/udp (both) for gaming pc, nothing else. Additional ports are required if you want to run a MW4 server, you don't need them for simply playing the game on multiplayer.


- Open router menu via web broser. Go to "Virtual Server". Create a new rule and set it to "enabled":

Name: MW4
Private IP: Must be your gaming pc's static lan ip, s.th. like
Protocol Type: Both
Private Port: 2300-2400
Public Port: 2300-2400
Schedule: Always

Save this and restart device - ready!

Hope that helps